Skip to main content

Topic: Neomonk21's 2005 Rubicon Build Thread (Read 2110 times)

0 Members and 1 Guest are viewing this topic.

  • 98tjcomeonuh
  • [*][*][*][*][*]
Re: Neomonk21's 2005 Rubicon Build Thread
Reply #121
In the lighting in my garage it looks red to me.  I was just bustin' his chops.
Oh I know, but impact Orange is one of my favorite colors on a jeep. So we'll go with impact orange ;D


  • Neomonk21
  • [*][*]
Re: Neomonk21's 2005 Rubicon Build Thread
Reply #123
Took it out on the highway this morning and it drove just fine.  I still can't say it's 100% fixed but my confidence is growing each day.

On a side note, I was replacing the side marker light that went out.  The housing had some water in it so I figured the bulb shorted and blew.  When I pulled the bulb out I noticed the bulb had water in it!  I never saw that one before.

  • G Beasley
  • [*][*][*][*][*]
  • Admin
  • Sawzall Surgeon
Re: Neomonk21's 2005 Rubicon Build Thread
Reply #124
Fluid dampened bulb ?!?


  • Neomonk21
  • [*][*]
Re: Neomonk21's 2005 Rubicon Build Thread
Reply #126
Yay, more problems!

Jeep seemed to be vibrating more than usual this morning.  I figured with the cold it just had a flat spot on one of the tires.  Then a few miles down the road it really started running like crap.  It was hesitating really bad over 2k RPM.

I was able to limp it home and put the code reader on it.  It's throwing P0203 which indicates a bad injector on cylinder 3 (or bad wiring, which I hope isn't the case). 

Is it worth replacing all injectors or should I be good with just replacing the bad one?

  • Florpro
  • [*][*][*][*][*]
Re: Neomonk21's 2005 Rubicon Build Thread
Reply #127
Yay, more problems!

Jeep seemed to be vibrating more than usual this morning.  I figured with the cold it just had a flat spot on one of the tires.  Then a few miles down the road it really started running like crap.  It was hesitating really bad over 2k RPM.

I was able to limp it home and put the code reader on it.  It's throwing P0203 which indicates a bad injector on cylinder 3 (or bad wiring, which I hope isn't the case). 

Is it worth replacing all injectors or should I be good with just replacing the bad one?
How many miles are on your jeep?

  • Neomonk21
  • [*][*]
Re: Neomonk21's 2005 Rubicon Build Thread
Reply #128
How many miles are on your jeep?

91,000

I finally got the injector replaced and it seems to be working just fine.  The injector rail went in WAY too easy.  It was such a pain to get out.  I did lube the o-rings but it still went in WAY too easy.  It has me concerned.  I ran my Jeep and allowed it to get up to temp.  I drove it around a bit and it wasn't squirting gas so we'll see.

  • G Beasley
  • [*][*][*][*][*]
  • Admin
  • Sawzall Surgeon
Re: Neomonk21's 2005 Rubicon Build Thread
Reply #129
If its running smooth and your not leaking any fuel you are good.

  • Neomonk21
  • [*][*]
Re: Neomonk21's 2005 Rubicon Build Thread
Reply #130
Something I noticed the past few days since I swapped the injector.  When starting off from idle, when I first give it gas I notice the RPMs will dip like its going to stall.  If I give it more gas it recovers just fine.  And sometimes at idle the RPMs will dip slightly and then go back up.  Any ideas?


ETA:  This doesn't happen every time.  Just occasionally.  Seems to happen less once its warm but that could be me not noticing once I get going.  Fuel filter maybe?
  • Last Edit: Jan 11, 2017, 08:49 AM by Neomonk21

  • bobthetj03
  • [*][*][*][*][*]
  • I'm not worthy!
Re: Neomonk21's 2005 Rubicon Build Thread
Reply #131
Your jeep doesn't have a fuel filter, just a strainer in the tank. Maybe a TPS?
My Jeep takes me to some pretty cool places!

  • Florpro
  • [*][*][*][*][*]
Re: Neomonk21's 2005 Rubicon Build Thread
Reply #132
Your jeep doesn't have a fuel filter, just a strainer in the tank. Maybe a TPS?
Fuel pump?


  • Neomonk21
  • [*][*]
Re: Neomonk21's 2005 Rubicon Build Thread
Reply #134
I put in a can of Sea Foam with this last tank and the engine is running real smooth.  I still have what feels like a slight hesitation and loss of power.  I'm going to try the TPS and if that doesn't fix it then I'll do the fuel pump.